Back to overview
Degraded

Fresh Restaurants App and Web orders not processing

Oct 17 at 12:02am EDT
Affected services
order.freshplantpowered.com - CLOUD
Fresh Mobile App

Resolved
Oct 20 at 04:45pm EDT

This issue has been resolved. After testing, we can confirm orders are working. If still facing issues, please call the IT Service Desk, and one of our analysts will assist you further.

IT Service Desk

Created
Oct 17 at 12:02am EDT

Please be advised that the Fresh Online order portal and Fresh App are currently experiencing technical issues, which may affect your ability to place orders. We understand the inconvenience this may cause, The team is investigating the issue and stores may receive more calls from guests to place orders. We will provide another update tomorrow morning.

Thank you,
Recipe IT