Back to overview
Degraded

Intermittent Website Connectivity Issues

Feb 27 at 01:40pm EST
Affected services
Brand Websites

Resolved
Feb 27 at 01:48pm EST

Our networking team has applied a fix, and we can confirm that the connectivity issues are now resolved. Guests should now be able to place orders through our brand websites without interruption.

Thank you for your patience.

Created
Feb 27 at 01:40pm EST

We are currently experiencing intermittent connectivity issues across our brand websites. During these outages, guests may be unable to place orders directly through the websites. While our networking team investigates the issue, guests can still place orders via the mobile app or through our call center. We will provide a further update shortly.