Back to overview
Degraded

Outage- Rogers iTel internet accounts

Aug 13 at 10:02am EDT
Affected services
Rogers internet

Updated
Aug 13 at 10:36am EDT

The ISP is still investigating the issue, and we are continuously monitoring the situation with them. Please continue to log a portal ticket at Web Portal, and will get back to you as soon as possible. We appreciate your patience with us.

Created
Aug 13 at 10:02am EDT

We are experiencing issues with the internet accounts at multiple stores that use Rogers iTel. We are currently escalating this matter with our Internet Service Provider to resolve it efficiently. Please log a portal ticket regarding this issue. We will provide an update as soon as we have new information.